Web admin page blank

Home Forums MongooseIM Web admin page blank

This topic contains 4 replies, has 3 voices, and was last updated by  erszcz 1 year, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #63497



    I just installed mongooseim on Centos 7 64 bits. It starts fine, no errors on logs. On the configuration I only added an admin user:

    {acl, admin, {user, “admin”, “localhost”}}

    when I access http://myipaddress:5280/admin/

    there’s no errors. Just an amazing white page. It doesn’t prompt for username or password. I tried to restart the services a couple of time but it doesn’t seem to affect and the logs seem okay.

    Any ideas?


    Mike Silvers

    Any luck on this? I am having the same problem.



    MongooseIM doesn’t support the old ejabberd-style web admin panel. That panel was buggy, didn’t really allow for complete configuration of the server and was dropped to minimize maintenance burden. There’s no web interface to the server at the moment. Depending on what you want to do please use the JSON metrics API, one of Exometer metrics publishers or mongooseimctl for admin tasks (possibly with some extra mod_admin_* modules that have to be loaded from ejabberd.cfg).

    • This reply was modified 1 year, 2 months ago by  erszcz.


    I’ve enabled JSON metrics API following MongooseIM documentation but I just get 404 responses. Do you know if MongooseIM supports xml_rpc calls like ejabberd?



    REST metrics API is described here: http://mongooseim.readthedocs.org/en/latest/developers-guide/REST-interface-to-metrics/
    When I curl the suggested metrics URL I get the following (jq is there just for readability):

    $ curl http://localhost:5280/api/metrics/ 2>/dev/null | jq .metrics[]

    Please note that by default MongooseIM is intentionally configured to only accept metrics requests from the local host. It’s due to the fact that the same interface can be used to perform actions (like deleting users). You can change this by adjusting ejabberd.cfg – change localhost to _ – but keep in mind it is not advised when running a server exposed in an untrusted network (like internet):

    ` { 5280, ejabberd_cowboy, [
    {num_acceptors, 10},
    {max_connections, 1024},
    {modules, [
    %% Modules used here should also be listed in the MODULES section.
    --> {"localhost", "/api", mongoose_api, [{handlers, [mongoose_api_metrics,
    {“_”, “/http-bind”, mod_bosh},
    {“_”, “/ws-xmpp”, mod_websockets}
    %% Uncomment to serve static files
    %{“_”, “/static/[...]“, cowboy_static,
    % {dir, “/var/www”, [{mimetypes, cow_mimetypes, all}]}

    • This reply was modified 1 year, 2 months ago by  erszcz.
    • This reply was modified 1 year, 2 months ago by  erszcz.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.