Lager undef error

Home Forums MongooseIM Lager undef error

This topic contains 4 replies, has 2 voices, and was last updated by  erszcz 1 year, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #57136


    Hi All,

    I have installed the precompiled MongooseIM package for OS X from Erlang Solutions. I have compiled a test and when I execute it, I get an error on the following piece of code: ?DEBUG(” MOD_TEST Started”,[]),

    The error is:
    2015-04-19 18:01:32.217 [critical] <0.194.0>@gen_mod:start_module:93 Problem starting the module mod_ymac_interceptor for host <<”localhost”>>
    options: []
    error: undef
    [{lager,debug,[" MOD_TEST Started",[]],[]},

    It seems as if lager was not correctly installed\compiled. I have tried compiling lager but the precompiled MongooseIM does not seem to like it.

    Any help on how to resolve this is greatly appreciated.




    Hi yogenr,

    Please make sure you compile mod_ymac_interceptor with lager’s parse transform. If you grab MongooseIM source code and drop your module .erl file into apps/ejabberd/src, then the parse transform will be applied automatically. Of course, all the other approaches to enable that parse transform on this module will also work.




    Hi Radek,

    Thanks for your response. I am new to erlang and have spent a fews days trying to compile and install MongooseIM with no success. The process generates a few errors which I am not able to understand or fix. I have thus decided to revisit this at a later stage when I have a better understanding of the various components.

    I have thus opted to go the route of installing the precompiled MongooseIM package, which installed with no problems. Could I ask if you could please provide an example of how to enable the parse transform on the module which does not require compiling the MongooseIM source code.

    Many thanks



    I have given up on getting mongooseim to work on OS X.

    Decided to setup a vm with Ubuntu. Installed Erlang. Installed MongooseIM. Ran test app… working 100%. Happy days.



    While I can’t help you with the particular problem, given lack of details, I am sure MongooseIM works fine on MacOSX too. I use it on a Mac daily.
    Still, good your problem is solved.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.